Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
UA to DA connection
May 17, 2017
0:50, EET
Avatar
peterrob45
Member
Members
Forum Posts: 25
Member Since:
March 9, 2017
sp_UserOfflineSmall Offline

Hi,
I have been trying to establish a connection between UA Client and Prosys DA server v1.7.5.21. and i am using Uagateway 1.4.3.268.
1) I can able to connect my Prosys UA server and DA server to the gateway.
2) I can able to see my UA client can connect to the Uagateway.

I tried to read a value from my UA client using a gateway, and it ended up with an error.
for example, i manually defined the NodeID “NodeId(5, “Counter1″)” and i tried to get the output of it failed like, Bad_NodeIdUnknown (0x80340000) “The node id refers to a node that does not exist in the server address space.”
And i tried to browse the DA address space its also not working, i even changed the ForceDa2Browsing to true in my uagateway.config.xml file and restarted.
My question is how can we get a value from the UA and DA server, I am looking for some tutorial documents. Looking for your help

May 18, 2017
11:44, EET
Avatar
Heikki Tahvanainen
Moderator
Members

Moderators
Forum Posts: 270
Member Since:
April 17, 2013
sp_UserOfflineSmall Offline

Hello,

Thank you for the question. The Bad_NodeIdUnknown error probably results simply because the node is not available in the UaGateway address space. UaGateway will modify the NodeIds so you should look up the NodeIds from the UaGateway and not from the underlying servers directly. In this specific case, the Prosys OPC UA Simulation Server contains node NodeId(5, “Counter1″) but when accessed through the UaGateway the NodeId will not be the same. This is expected behaviour and completely correct.

The bigger issue is that the connection between UaGateway and the Prosys OPC Simulation Server isn’t probably working correctly. The browsing should work with default settings.

Are the UaGateway and the Prosys OPC Simulation Server installed on the same host computer? Are they both running under the same user account?

May 19, 2017
13:00, EET
Avatar
peterrob45
Member
Members
Forum Posts: 25
Member Since:
March 9, 2017
sp_UserOfflineSmall Offline

Hi Heikki,
As you said, I found the Node ID in the address space has changed when my I connect my server to my Uagateway. I browsed the address space using sample client and now I can able to access the values of both my UA and DA server.

As you asked in the previous post, all servers, Uagateway and my UA client are on the same PC. Now I would like to put my DA server to the other computer and connect. So what changes should I do for example:
where should I put my Uagateway? where my server is located or in my client location?

Thanks

May 19, 2017
13:12, EET
Avatar
Heikki Tahvanainen
Moderator
Members

Moderators
Forum Posts: 270
Member Since:
April 17, 2013
sp_UserOfflineSmall Offline

Hello,

Good to know that the issues were solved.

Our recommendation is to always install UaGateway and the OPC Classic application (in this case OPC DA server) on the same host computer and to run them using the same user account. This will minimize the need for COM/DCOM configuration which can be problematic. Remote OPC UA connections in turn work very well. To put it shortly: the UaGateway should be installed in the server location.

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 78

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

pramanj: 86

hbrackel: 74

ibrahim: 65

kapsl: 57

gjevremovic: 49

TimK: 41

fred: 36

Fransua33: 35

Rainer Versteeg: 32

peterrob45: 25

Member Stats:

Guest Posters: 0

Members: 652

Moderators: 10

Admins: 1

Forum Stats:

Groups: 3

Forums: 14

Topics: 685

Posts: 2953

Newest Members:

Ravish Roshan, Max Braun, Predixer, LorraineXu, FF, Jonas, HA198273465, RaeHoffman, susandaigle23, m.scaglioni

Moderators: Jouni Aro: 801, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 230, Heikki Tahvanainen: 270, Jukka Asikainen: 1

Administrators: admin: 0