Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Simulation server start fails with "Invalid URL"
December 13, 2019
11:19, EET
Avatar
sve
New Member
Members
Forum Posts: 2
Member Since:
December 13, 2019
sp_UserOfflineSmall Offline

I’m having trouble starting the simulation server on Ubuntu 16.04. I get an error message saying “ERROR: Server not started: Invalid URL”. UA TCP address is opc.tcp://advantech:53530/OPCUA/SimulationServer

I’m using server version 4.0.0.-105

December 13, 2019
15:20, EET
Avatar
Bjarne Boström
Moderator
Moderators
Forum Posts: 695
Member Since:
April 3, 2012
sp_UserOfflineSmall Offline

Hi,

Could you check your /.prosysopc/prosys-opc-ua-simulation-server/log/simulationserver.log for an error stacktrace and paste it here (or alternatively to uajava-support@prosysopc.com)?

December 14, 2019
13:02, EET
Avatar
sve
New Member
Members
Forum Posts: 2
Member Since:
December 13, 2019
sp_UserOfflineSmall Offline

The relevant part is probably contained here:

12/13/2019 10:14:23.552 INFO [ForkJoinPool.commonPool-worker-3] com.prosysopc.ua.stack.transport.b.c [] – Endpoint bound to opc.https://advantech:53443
12/13/2019 10:14:23.578 ERROR [JavaFX Application Thread] com.prosysopc.ua.app.simserver.windows.MainWindow [] – Server not started
java.lang.IllegalArgumentException: Invalid URL
at com.prosysopc.ua.stack.utils.l.e(SourceFile:844) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.stack.utils.l.eZ(SourceFile:758) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.stack.a.e.a(SourceFile:221) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.server.ap.au(SourceFile:2133) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.server.ap.start(SourceFile:6160) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.app.simserver.d.g(SourceFile:214) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.app.simserver.d$1.bS(SourceFile:136) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at com.prosysopc.ua.app.simserver.d$1.call(SourceFile:120) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
at javafx.concurrent.Task$TaskCallable.call(Task.java:1425) ~[javafx-graphics-13-mac.jar:?]
at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]
at java.util.concurrent.CompletableFuture.biRun(CompletableFuture.java:1375) ~[?:?]
at java.util.concurrent.CompletableFuture$BiRun.tryFire(CompletableFuture.java:1356) ~[?:?]
at java.util.concurrent.CompletableFuture$Completion.exec(CompletableFuture.java:479) ~[?:?]
at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:290) ~[?:?]
at java.util.concurrent.ForkJoinPool$WorkQueue.topLevelExec(ForkJoinPool.java:1020) ~[?:?]
at java.util.concurrent.ForkJoinPool.scan(ForkJoinPool.java:1656) ~[?:?]
at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1594) ~[?:?]
at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:177) ~[?:?]
Caused by: java.net.URISyntaxException: Illegal character in scope id at index 44: opc.https://[fe80:0:0:0:42:b8ff:fef4:b67b%br-986508d2caaf]:53443
at java.net.URI$Parser.fail(URI.java:2915) ~[?:?]
at java.net.URI$Parser.checkChars(URI.java:3086) ~[?:?]
at java.net.URI$Parser.parseServer(URI.java:3286) ~[?:?]
at java.net.URI$Parser.parseAuthority(URI.java:3218) ~[?:?]
at java.net.URI$Parser.parseHierarchical(URI.java:3160) ~[?:?]
at java.net.URI$Parser.parse(URI.java:3116) ~[?:?]
at java.net.URI.(URI.java:600) ~[?:?]
at com.prosysopc.ua.stack.utils.l.e(SourceFile:778) ~[ui-javafx-4.0.0-105.jar:4.0.0-105]
… 17 more
(END)

December 16, 2019
16:09, EET
Avatar
Markus Johansson
Moderator
Members

Moderators
Forum Posts: 36
Member Since:
August 6, 2019
sp_UserOfflineSmall Offline

Hi, and thanks for the informative log excerption! It seems that the scope id of your IPv6 address contains the “-” character which is rejected by the Java URI parser.

If you don’t need to use IPv6 addresses in Simulation Server, you can go to the installation folder and find the settings.xml file. There you should search for the “useIPv6” field and change the value to false. This should hopefully solve the issue.

April 22, 2020
12:33, EEST
Avatar
hans
New Member
Members
Forum Posts: 1
Member Since:
April 22, 2020
sp_UserOfflineSmall Offline

@Markus, I also aware the same problem and tried to disable the IPv6 configure in settings.xml. unfortunately, it doesn’t work for me. The only way to workaround is reboot my ubuntu VM and restart OPC UA server again. Do you have any idea about this?

April 27, 2020
14:11, EEST
Avatar
Markus Johansson
Moderator
Members

Moderators
Forum Posts: 36
Member Since:
August 6, 2019
sp_UserOfflineSmall Offline

hans said
@Markus, I also aware the same problem and tried to disable the IPv6 configure in settings.xml. unfortunately, it doesn’t work for me. The only way to workaround is reboot my ubuntu VM and restart OPC UA server again. Do you have any idea about this?  

Hi,

I cannot say what could be causing this. Would it be possible for you to zip the “log” folder (next to the “settings.xml” file) and send it to support@prosysopc.com after the error happens?

June 13, 2020
1:57, EEST
Avatar
ebaklund
New Member
Members
Forum Posts: 1
Member Since:
June 13, 2020
sp_UserOfflineSmall Offline

Hi,
I also had the same problem on Ubuntu 18.04 LTS : “ERROR: Server not started: Invalid URL”
Setting “useIPv6” to “false” did not work for me, but changing Endpoint Bind Address from “All” to “Custom” did. Laugh

June 15, 2020
23:43, EEST
Avatar
marielena90
espana
New Member
Members
Forum Posts: 1
Member Since:
June 15, 2020
sp_UserOfflineSmall Offline

Solution is to disable http2 in your /etc/nginx/conf.d/rocket.chat.conf:

server {
#listen 443 ssl http2 default_server;
listen 443 ssl default_server;
#listen [::]:443 ssl http2 default_server;

June 16, 2020
9:22, EEST
Avatar
Bjarne Boström
Moderator
Moderators
Forum Posts: 695
Member Since:
April 3, 2012
sp_UserOfflineSmall Offline

Hi,

We are aware of the issue, should be fixed in the next release (which might take some time still due to other changes).

The reason is that our SDK didn’t handle IPv6 addresses exactly properly if there are scopes, it is fixed in the SDK 4.3.0, but the current release version of the application uses older SDK version.

Also it might be that my earlier suggestion of the useIPv6 option wont help since we might fail before we even get to that point internally. However the custom endpoint instead of all mentioned above should work.

February 8, 2021
12:25, EET
Avatar
Yash_Joshi_Pratiti
Member
Members
Forum Posts: 3
Member Since:
February 8, 2021
sp_UserOfflineSmall Offline

Hello,Yash Joshi here,new to the forum,

I have the same Issue:
1) Tried to update the settings.xml, but realised there is no such file in /home/user/.prosysopc/prsosys-opc-ua-simulation-server/
2) Tried changing to the Custom endpoint from the ‘All’, but the server doesn’t absorb the changes, the changes are never recorded and the next time i start the server, the changes are as they were earlier.
3) I tried uninstalling and installing version 5.0.0, but no use,same issue.
4) tried updating the file /etc/nginx/conf.d/rocket.chat.conf, but realised there is no nginx directory there too.

uname -a gives:
Linux user 5.3.0-46-generic #38~18.04.1-Ubuntu SMP Tue Mar 31 04:17:56 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

February 8, 2021
15:55, EET
Avatar
Markus Johansson
Moderator
Members

Moderators
Forum Posts: 36
Member Since:
August 6, 2019
sp_UserOfflineSmall Offline

Yash_Joshi_Pratiti said
1) Tried to update the settings.xml, but realised there is no such file in /home/user/.prosysopc/prsosys-opc-ua-simulation-server/
2) Tried changing to the Custom endpoint from the ‘All’, but the server doesn’t absorb the changes, the changes are never recorded and the next time i start the server, the changes are as they were earlier.
 

Hi,

The “settings.xml” is not in use in newer versions of Simulation Server. so you need to edit the “serverSettings.xml” file instead. There you can find the fields and to customize the options for using IPv6 and toggling the Endpoint Bind Addresses settings between “All” and “Custom”. If you are missing the settings file altogether, then it needs to be resolved by email. Yash Joshi, I sent you an email also.

February 9, 2021
7:03, EET
Avatar
Yash_Joshi_Pratiti
Member
Members
Forum Posts: 3
Member Since:
February 8, 2021
sp_UserOfflineSmall Offline

Markus Johansson said

Yash_Joshi_Pratiti said
1) Tried to update the settings.xml, but realised there is no such file in /home/user/.prosysopc/prsosys-opc-ua-simulation-server/
2) Tried changing to the Custom endpoint from the ‘All’, but the server doesn’t absorb the changes, the changes are never recorded and the next time i start the server, the changes are as they were earlier.
 

Hi,

The “settings.xml” is not in use in newer versions of Simulation Server. so you need to edit the “serverSettings.xml” file instead. There you can find the fields and to customize the options for using IPv6 and toggling the Endpoint Bind Addresses settings between “All” and “Custom”. If you are missing the settings file altogether, then it needs to be resolved by email. Yash Joshi, I sent you an email also.  

I received mail from the official support Engineer with the settings.xml file and putting it in the .prosysopc/prosys…/ directory solved my issue.

Thanks for your time. 😉

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
15 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 111

pramanj: 86

ibrahim: 74

kapsl: 57

gjevremovic: 49

Xavier: 42

TimK: 41

fred: 41

Fransua33: 39

rocket science: 36

Member Stats:

Guest Posters: 0

Members: 1590

Moderators: 17

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1192

Posts: 5057

Newest Members:

warnerfleming, Raymond23Freex, Charles1UsadY, Robertvem, albertinaduff53, wilbertrignall, Rogerbeedo, letamunn4183992, Lizazooda, Hectorner

Moderators: Jouni Aro: 914, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 695, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Jimmy Ni: 24, Teppo Uimonen: 21, Markus Johansson: 36, Niklas Nurminen: 0, Matti Siponen: 161, Lusetti: 0

Administrators: admin: 1