Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Problems trying to establish a connection via HTTPS OPC UA Browser and OPC UA Simulation Server
October 22, 2020
18:10, EET
Avatar
aldayr
New Member
Members
Forum Posts: 2
Member Since:
October 22, 2020
sp_UserOfflineSmall Offline

Hi,I’m a begginer in OPC UA and.

I have the free version of OPC UA Browser and OPC UA Simulation Server
When I try to establish a connection via https, the OPC UA Browser pops up a menu where I have to select the server I want to connect. Then, when I click the server, the same menu(server selection) appears again(a loop). But the connection never gets established. The UA TCP connection works well.

I have the UA HTTPS enabled with port 51443. And I don’t get wrong typing the connection beucase as I said I can see the server I want to select.
I tried creating a user and password to get connected but anythig works.

How can I solve this?

Sorry for my english and thanks.

October 23, 2020
11:03, EET
Avatar
Matti Siponen
Moderator
Members

Moderators
Forum Posts: 72
Member Since:
February 11, 2020
sp_UserOfflineSmall Offline

Hello,

Simulation Server’s certificate for opc.https connections is not self-signed, so you’ll have to trust the certification authority (CA) certificate that was used to sign it to in order to form a connection. At the moment this has to be done manually by copying SimulationServerCA.der from \.prosysopc\prosys-opc-ua-simulation-server\PKI\CA\private to \.prosysopc\prosys-opc-ua-browser\PKI\CA\certs, where is your home folder where .prosysopc folder is located. If you do not perform this step, you will see the menu appear again and again.

If you’re using 4.0.4-247 or a newer version of Browser, then there is a programming oversigth that prevents Browser from connecting to Simulation Server via opc.https. Newer versions of Browser require that a CA certificate provides a certificate revocation list (CRL) that can be used to check the revocation status of certificates they have signed. See the OPC UA Specification for more information on the topic (https://reference.opcfoundation.org/v104/Core/docs/Part4/6.1.3/). However, the CA certificate used by Simulation Server doesn’t provide a CRL, which results in all certificates signed by the CA being treated as invalid preventing Browser from connecting to Simulation Server via opc.https.

Upcoming versions of Browser shall no longer require CA certificates to provide CRLs. Since you also contacted us by email, I shall send you a download link to a beta build of Browser that contains this change. Let us know if that solves the issue you’re facing.

October 23, 2020
17:58, EET
Avatar
aldayr
New Member
Members
Forum Posts: 2
Member Since:
October 22, 2020
sp_UserOfflineSmall Offline

I was using Browser version 4.0.4, I installed beta version and it worked.
Thank you.

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online: Jouni Aro, MichaelBraveDigital
11 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 103

pramanj: 86

ibrahim: 70

kapsl: 57

gjevremovic: 49

TimK: 41

Fransua33: 39

fred: 38

Rainer Versteeg: 32

Thomas Reuther: 31

Member Stats:

Guest Posters: 0

Members: 1160

Moderators: 15

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1048

Posts: 4416

Newest Members:

jonas.rahm, sophiekohler, zqecortney, adeletoscano947, forestgenders23, auroratrumper, ericmclain04, rblu, starlowery23194, dakotadalgety82

Moderators: Jouni Aro: 853, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 579, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Teppo Uimonen: 21, Markus Johansson: 24, Matti Siponen: 72, Lusetti: 0

Administrators: admin: 1