Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Persisting a new simulation variable?
October 2, 2020
22:01, EEST
Avatar
ray
Member
Members
Forum Posts: 11
Member Since:
October 2, 2020
sp_UserOfflineSmall Offline

Hi,
When I created a new simulation variable using “Add Node” -> “Add Variable”, I set its signal type to Constant and its data type to UIInt16. But as I move to other pages and come back to check the variable, I see it always reverts back to data type of Double. Is there a way to persist the attributes of a newly created simulation variable?

Thanks,
Ray

October 5, 2020
9:38, EEST
Avatar
Matti Siponen
Moderator
Members

Moderators
Forum Posts: 79
Member Since:
February 11, 2020
sp_UserOfflineSmall Offline

Hello,

Which version of the Prosys OPC UA Simulation Server you’re using? I tried to replicate your problem with version 5.0.2-242 and I was unable to replicate it. If possible, I would recommend you to try downloading the newest release of Simulation Server from https://downloads.prosysopc.com/opc-ua-simulation-server-downloads.php and see if that fixes the problem for you.

October 5, 2020
16:45, EEST
Avatar
ray
Member
Members
Forum Posts: 11
Member Since:
October 2, 2020
sp_UserOfflineSmall Offline

Thanks Matti. I upgraded the server from 4.* to 5.* as you suggested and now I can create a variable with the desired type.
A related question: is this a feature of the server that every time I create a new simulated object I need to restart the server to see it in the address space? Is there any way to make the variable visible without a restart?

Thanks,
Ray

October 6, 2020
8:27, EEST
Avatar
Matti Siponen
Moderator
Members

Moderators
Forum Posts: 79
Member Since:
February 11, 2020
sp_UserOfflineSmall Offline

Refreshing the parent Node you added a new simulated object to should be sufficient to make it visible in the AddressSpace. Go to the Address Space tab, browse to the parent Node, right click the parent Node, click Refresh and the newly added simulated object should appear.

October 6, 2020
16:49, EEST
Avatar
ray
Member
Members
Forum Posts: 11
Member Since:
October 2, 2020
sp_UserOfflineSmall Offline

yup! right again:-) Thx.

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 103

pramanj: 86

ibrahim: 70

kapsl: 57

gjevremovic: 49

TimK: 41

Fransua33: 39

fred: 38

Thomas Reuther: 33

Rainer Versteeg: 32

Member Stats:

Guest Posters: 0

Members: 1186

Moderators: 15

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1059

Posts: 4458

Newest Members:

gilbertvpj, ThoreB, Gwind, angleamohammad, steffenk41, smartin2k, peterjmf69, juliusdavidson, linettemacandie, RajiMenon

Moderators: Jouni Aro: 857, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 581, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Teppo Uimonen: 21, Markus Johansson: 28, Matti Siponen: 79, Lusetti: 0

Administrators: admin: 1