Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Headless / UI-less Modus gateway?
October 25, 2016
19:50, EEST
Avatar
hbrackel
Member
Members
Forum Posts: 103
Member Since:
February 21, 2014
sp_UserOfflineSmall Offline

Hi,

I’m currently evaluating the functionality of the ProsysOPC Modus gateway. We actually would like to deploy the Modus Gateway on a headless LINUX box. Would there be any way to remotely configure the Modus server and to “detach” the UI part of it?

Thanks,
Hans-Uwe

October 26, 2016
14:10, EEST
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 851
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

Yes, in principle this should work.

You should create the configuration on a box with UI. You can then copy the devicesConfig.xml to the headless box – the location is on Linux at ‘/etc/ProsysOPC/ModbusServer’

If you then run the application as service (as instructed in the manual), it should run fine.

The application log will be in the same folder under name ‘app.log’ and can be used to verify that the application starts up.

Also, you will need to copy the license file manually to ‘/etc/ProsysOPC/ModbusServer/license/License.lic’ to run the licensed version.

This hasn’t been tested too much, though, and since it is using a virtual display to “hide” the UI in this case, there are some uncertainties in how it works in practice. So, please let us know how it works for you.

November 24, 2016
12:17, EEST
Avatar
hbrackel
Member
Members
Forum Posts: 103
Member Since:
February 21, 2014
sp_UserOfflineSmall Offline

Good morning,

first of all I’m happy to confirm, that running the ModbusTCP server on a headless RHEL box works nicely.We experienced some initial problems due to a certain (abnormal) version of the glibc on our system, but after going back to the standard version the ModbusTCP server could be installed. I received the license file yesterday and will try this out today.

2 follow up questions arose for this setup:
1) How can the allowed security options for the endpoints be adjusted/configured? While the UI provides checkboxes to select the endpoint security, I couldn’t find any configuration file to adjust this for a headless server.
2) We would like to provide the server with our own certificates, in particular the subject, organisation etc. Is this possible?

Some minor suggestions for improvements regarding the rpm package:
1) the folder in /etc should be created at the installation time and not only when the application is started
2) following common practices, the ModbusServer folder should reside directly underneath /etc (not /etc/ProsysOPC/ModbusServer
3) for security reasons, the RPM installer should create a dedicated user which owns the configuration directories and under whose account the executable is started

Of course, all of the above, with the exception of the nested folders, can be accomplished manually. It would just be a little more convenient to have all this included in the RPM. It is possibly desired for the UI version on a Linux box to behave as is currently implemented.

Thanks,
Hans-Uwe

November 25, 2016
12:08, EEST
Avatar
Bjarne Boström
Moderator
Moderators
Forum Posts: 545
Member Since:
April 3, 2012
sp_UserOfflineSmall Offline

Hi,

This is nice to hear, good that you got it working.

Question answers:
1) Similarry as in other settings, by coping the settings file from a machine that has a UI. You could also edit the configuration XML file manually at /etc/ProsysOPC/ModbusServer/serverConfig.xml:

<securityModes>
<securityMode messageMode="Sign" securityPolicy="http://opcfoundation.org/UA/Se…..;/&gt;
<securityMode messageMode="None" securityPolicy="http://opcfoundation.org/UA/Se…..;/&gt;
<securityMode messageMode="SignAndEncrypt" securityPolicy="http://opcfoundation.org/UA/Se…..;/&gt;
<securityMode messageMode="Sign" securityPolicy="http://opcfoundation.org/UA/Se…..;/&gt;
<securityMode messageMode="SignAndEncrypt" securityPolicy="http://opcfoundation.org/UA/Se…..;/&gt;
</securityModes>

If you remove some of those, then that mode is not available (except if you delete all, then None is used). You do need to restart the server to apply new changes.

2) You can replace the certificates at /etc/ProsysOPC/ModbusServer/PKI/CA/private and …/PKI/certs. Note the this currently only works if the private key is without password.

Regarding suggestions:
Thanks! We will try to see if these can be made in a future update. I suppose I should note that the installers are made with the javapackager tool that comes with the JDK. While we have done some customization, some of the logic is based on the tools defaults. Also we would prefer to have some folder structures probably same in all OS if possible.

We do have plans to make the headless experience better.

– Bjarne

December 1, 2016
17:28, EEST
Avatar
hbrackel
Member
Members
Forum Posts: 103
Member Since:
February 21, 2014
sp_UserOfflineSmall Offline

Hi,

I’m struggling a bit to get the license file accepted. I copied the file into the location /etc/ProsysOPC/ModbusServer/license and renamed it to “License.lic” as described above in the conversation. Unfortunately, neither of the licenses (with the hostname spelled in all capital letters or lower case letters) is accepted and the log shows a respective exception. Increasing the log-level showed that the hostname has been *recognised* correctly. Assuming the short version of the hostname is considered for the license check (and not the canonical hostname)

Would you have any suggestions of what could be the problem?

Thanks, Hans-Uwe

December 2, 2016
13:48, EEST
Avatar
Heikki Tahvanainen
Moderator
Members

Moderators
Forum Posts: 402
Member Since:
April 17, 2013
sp_UserOfflineSmall Offline

Hello Hans-Uwe,

I’m sorry to hear that you’re experiencing issues. There has been a bug in the Modbus Server which caused license file to not be validated correctly in some situations when computer hostname contains domain part.

We just released a new version 1.1.2 of the Modbus Server. Could you try reproducing the same error again with the newest version and report back if the issue still persists?

Br,
Heikki Tahvanainen

December 2, 2016
19:20, EEST
Avatar
hbrackel
Member
Members
Forum Posts: 103
Member Since:
February 21, 2014
sp_UserOfflineSmall Offline

Hello Heikki,

just to also update the information on the forum: after updating to the new version of the ModbusServer (1.1.2) the license file has been recognized and the server is “happily” running.

Thanks a lot for your support.

– Hans-Uwe

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
10 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 103

pramanj: 86

ibrahim: 70

kapsl: 57

gjevremovic: 49

TimK: 41

Fransua33: 39

fred: 38

Rainer Versteeg: 32

Thomas Reuther: 31

Member Stats:

Guest Posters: 0

Members: 1105

Moderators: 14

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1009

Posts: 4268

Newest Members:

user1290, gregp, mariohetheringto, normagalindo47, aurelia27u, isobel41d356980, michaeldegli, gqbdolores, kez1399, jaclynmcvay358

Moderators: Jouni Aro: 851, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 545, Heikki Tahvanainen: 402, Jukka Asikainen: 1, Teppo Uimonen: 20, Markus Johansson: 19, Matti Siponen: 53, Lusetti: 0

Administrators: admin: 0