Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
UaExpert will not connect to OPC Server
February 12, 2013
22:31, EET
Avatar
KrisF
New Member
Members
Forum Posts: 2
Member Since:
February 12, 2013
sp_UserOfflineSmall Offline

When I attempt to connect UaExpert to my OPC Server, UaExpert logs “Connecting failed with error ‘BadServiceUnsupported’. Coincidentally, my OPC Server logs “ERROR Service CreateSessionRequest is not supported”. On the way to getting those errors, I am noticing that UaExpert is logging the ApplicationUri as ‘urn::’ whereas my OPC Server logs the ApplicationUri as ‘urn::UA:’. Clearly, they are different. UaExpert and my OPC server seem to be talking, but they are not on the same page. Please assist. Thank you.
Kris

February 13, 2013
7:34, EET
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 960
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

This indicates that your endpointUrl is not correct, so you get a connection to the server, but it does not handle your requests.

You can ensure that you get the correct endpoint by adding the url (or just the beginning, e.g. opc.tcp://localhost:52520, (replace 52520 with your the server port)) to the Custom Discovery part of UaExpert.

Or just copy one of the URLs your server reports to the console when it starts (if you have logging enabled).

February 13, 2013
13:58, EET
Avatar
KrisF
New Member
Members
Forum Posts: 2
Member Since:
February 12, 2013
sp_UserOfflineSmall Offline

Thanks for your response Jouni. I was able to connect this morning. Whereas I had been using opc.tcp://localhost:52520 as the Endpoint URL, I tried using opc.tcp://localhost:52520/OPCUA/OldiOPCServer instead. The latter worked. My OPC Server had logged …

02/13/2013 08:27:21.566 INFO Server endpoint bound to opc.tcp://localhost:52520/OPCUA/OldiOPCServer
02/13/2013 08:27:21.567 INFO Discovery endpoint bound to opc.tcp://localhost:52520

… as well as several other possibilities. As you suggested, I just copied the appropriate info from the log and it worked. Thanks again!

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
22 Guest(s)

Currently Browsing this Page:
2 Guest(s)

Top Posters:

hbrackel: 124

pramanj: 86

ibrahim: 74

rocket science: 65

kapsl: 57

Sabari: 51

gjevremovic: 49

Xavier: 43

fred: 41

TimK: 41

Member Stats:

Guest Posters: 0

Members: 1749

Moderators: 15

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1323

Posts: 5649

Newest Members:

WalterFOUNC, datafastproxiespx01, LenkaLok, seoninet, justinevillanuev, namtrott5457, DonaldWibip, AlfredoEthix, andreidla, everangel7021

Moderators: Jouni Aro: 960, Otso Palonen: 32, Tuomas Hiltunen: 5, Pyry: 1, Petri: 0, Bjarne Boström: 860, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Jimmy Ni: 25, Teppo Uimonen: 21, Markus Johansson: 42, Niklas Nurminen: 0, Matti Siponen: 222, Lusetti: 0

Administrators: admin: 1