Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Cannot connect to MSSQL database, Test Connection displays Could Not Connect: error msg
April 22, 2022
19:02, EEST
Avatar
gjdpk
New Member
Members
Forum Posts: 1
Member Since:
April 22, 2022
sp_UserOfflineSmall Offline

I’m trying to get OPC Server points / tags over to a database. I’m trying to use Prosys OPC UA Historian. I’ve installed MSSQL 2014 on a Windows 7 machine along with this Prosys program. I created a table in MSSQL2014. I start the Prosys software and in the Database Connection pop-up I select Microsoft SQL Server, localhost, the port that is listed in ( Sql Server Configuration Manager / Protocals / TCPIP / Properties / IP Addresses / IPALL / TCP Dynamic Ports), selected the instance / custom / my database instance name shown in SQL Managment Studio, and press “Test Connection”.

When I do this, and many variations of this, the message box next to the “Test Connection” button displays an error message, “Could not connect: I/O Error: SSO Failed: Native SSPI library not loaded. Check teh java.library.path system property.

Any thoughts?

I’ve also went through these step with MS SQL 2019 on a Windows 10 machine. Same results.

April 25, 2022
14:12, EEST
Avatar
Bjarne Boström
Moderator
Moderators
Forum Posts: 775
Member Since:
April 3, 2012
sp_UserOfflineSmall Offline

Hi,

Sorry for the problem.

Hmm for “… I created a table …”, you should not do that, the software will create all tables it needs (and basically needs all the permissions to do those). Also it is only tested so that it is the one who creates them; there is a “liquibase database versioning” system being used, I’m not 100% sure does it work if the table(s) existed already.

The manual is in the download page (or https://downloads.prosysopc.com/opcua/apps/Historian/dist/1.1.6-87/Prosys_OPC_UA_Historian_UserManual.pdf), there is an important step of MS SQL server, in section 1.2.3. The app cannot use the “native windows” authentication (there might be workarounds, we have not tried), so you must ensure TCP/IP Protocol is enabled and SQL Server Browser service is running. Also SQL Server Authentication must also be enabled.

Could you check that is done and does it fix the problem?

(Note that it has been a while since I have personally dealt Historian-related problems, so this is based on https://stackoverflow.com/questions/6356612/jtds-driver-not-working-for-sql-server-2008r2-and-denali-native-sspi-library-not for the error and the knowledge that it didn’t work when we developed Historian, though maybe now there would be a way to make it work per the post, though that is sort of outside support scope at least for now as it would be a new feature to support the native auth.)

P.S.
We probably should improve the dialog so it would tell this…

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online: Jerryinsop, Larryorarm
12 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 120

pramanj: 86

ibrahim: 74

rocket science: 65

kapsl: 57

gjevremovic: 49

Xavier: 42

fred: 41

TimK: 41

Fransua33: 39

Member Stats:

Guest Posters: 0

Members: 2891

Moderators: 17

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1261

Posts: 5369

Newest Members:

allisontz18, Elmer1493vok, AspectMontageAtrox, miloparris0, josettegrenier, berniceiy1, Sylviaser, gilbertstonge93, waldomarriott43, madgeroque72

Moderators: Jouni Aro: 930, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 775, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Jimmy Ni: 25, Teppo Uimonen: 21, Markus Johansson: 39, Niklas Nurminen: 0, Matti Siponen: 207, Lusetti: 0

Administrators: admin: 1