Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Prosys OPC UA Browser slow when is subscribed to a MQTT broker
June 5, 2023
20:02, EEST
Avatar
luismartin
Member
Members
Forum Posts: 3
Member Since:
June 5, 2023
sp_UserOfflineSmall Offline

Hi all,

This is my first message on this forum so, hello everybody.

I am testing the behaviour of the Prosys OPC UA browser, since I am interested in this product. However, when I have checked its capacities dealing with MQTT, I have discovered that the variables values are updated on the screen very slowly, although the MQTT publisher is publishing very fast (one new value per 100 ms). Instead, the Prosys OPC UA browser updates the values once each seconds (more or less).

Is this the right behaviour or maybe there is something wrong?

Best,
Luis

June 6, 2023
8:41, EEST
Avatar
Matti Siponen
Moderator
Members

Moderators
Forum Posts: 323
Member Since:
February 11, 2020
sp_UserOfflineSmall Offline

Hello,

Browser doesn’t have any limitations on how often the values in its UI are updated. I tested with Browser and Simulation Server running on the same host that Browser is able to handle updating values of 6 variables every 100 ms if the publisher is sending them that frequently. How many variables are you receiving values for?

Have you checked the Log tab on Browser to confirm that it is receiving messages once every 100 ms? Could you compare the logs from Browser to logs from the publisher and the broker to check if Browser is missing any messages?

June 6, 2023
11:29, EEST
Avatar
luismartin
Member
Members
Forum Posts: 3
Member Since:
June 5, 2023
sp_UserOfflineSmall Offline

Hi Matti Siponen,

Thank you for your quick answer. After reading it I have doublechecked the publisher configuration (Prosys OPC UA Simulation Server) and, oh my God, it was set up to update variables each 1 second, and not each 100 ms. I was watching the variables being updated super fast on the screen, but the values were being published each 1 second. I feel so stupid.

Thank you very much.

Best,
Luis

June 6, 2023
12:22, EEST
Avatar
Matti Siponen
Moderator
Members

Moderators
Forum Posts: 323
Member Since:
February 11, 2020
sp_UserOfflineSmall Offline

Hello,

The Values of the Variables on “Variable DataSets” subtab of PubSub tab are updated based on the simulation interval configured either on Objects or Types tab, but WriterGroups also have their own Publishing Interval that is separate from the simulation interval. Considering how many configuration parameters there are for PubSub as a whole, it is understandable to not consider the practical effects of them all. Perhaps there could be some notification displayed next to Publishing Interval when it and simulation interval are different to make this difference more noticeable.

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 518

Currently Online:
9 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 135

pramanj: 86

Francesco Zambon: 81

rocket science: 77

Ibrahim: 76

Sabari: 62

kapsl: 57

gjevremovic: 49

Xavier: 43

TimK: 41

Member Stats:

Guest Posters: 0

Members: 697

Moderators: 16

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1470

Posts: 6268

Newest Members:

luzescobedo63, liliana81q, MinniePries, 42or, kaisa, sonbranson085, Pedromon, dalevine155279, Tailor, BetseyJep

Moderators: Jouni Aro: 1012, Otso Palonen: 32, Tuomas Hiltunen: 5, Pyry: 1, Petri: 0, Bjarne Boström: 983, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Jimmy Ni: 26, Teppo Uimonen: 21, Markus Johansson: 42, Niklas Nurminen: 0, Matti Siponen: 323, Lusetti: 0, Ari-Pekka Soikkeli: 5

Administrators: admin: 1