Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Prosys OPC UA server is failing during installation
March 18, 2019
8:55, EEST
Avatar
Sayan B
New Member
Members
Forum Posts: 1
Member Since:
March 18, 2019
sp_UserOfflineSmall Offline

Hi All,

I am facing below error message while installing Prosys OPC UA simulation server in my debian box.
I have used this command -> sudo dpkg -i prosys-opc-ua-simulation-server-3.2.0-214.deb

error message:
———————
Preparing to unpack prosys-opc-ua-simulation-server-3.2.0-214.deb …
Removing shortcut
/var/lib/dpkg/info/prosys-opc-ua-simulation-server.prerm: 24: /var/lib/dpkg/info/prosys-opc-ua-simulation-server.prerm: xdg-desktop-menu: not found
dpkg: warning: old prosys-opc-ua-simulation-server package pre-removal script subprocess returned error exit status 127
dpkg: trying script from the new package instead …
dpkg: … it looks like that went OK
Unpacking prosys-opc-ua-simulation-server (3.2.0-214) over (3.2.0-214) …
Setting up prosys-opc-ua-simulation-server (3.2.0-214) …
Adding shortcut to the menu
/var/lib/dpkg/info/prosys-opc-ua-simulation-server.postinst: 25: /var/lib/dpkg/info/prosys-opc-ua-simulation-server.postinst: xdg-desktop-menu: not found
dpkg: error processing package prosys-opc-ua-simulation-server (–install):
installed prosys-opc-ua-simulation-server package post-installation script subprocess returned error exit status 127
Errors were encountered while processing:
prosys-opc-ua-simulation-server

Any suggestion would be very helpful.Smile

March 20, 2019
10:54, EEST
Avatar
Bjarne Boström
Moderator
Moderators
Forum Posts: 336
Member Since:
April 3, 2012
sp_UserOfflineSmall Offline

Hi,

Based on the internet this could be a bug in xdg-util package (based on discussion at https://github.com/cryptomator/cryptomator/issues/498, it had same error message, apparently Ubuntu would have fixed that, but Debian not). You could try the workaround mentioned there, which is manually creating the missing directory like this:

mkdir /usr/share/desktop-directories/

and after that

apt -f install

.

Please let us know if this did resolve the problem

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 78

Currently Online:
11 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 89

pramanj: 86

ibrahim: 68

kapsl: 57

gjevremovic: 49

TimK: 41

Fransua33: 39

fred: 36

Rainer Versteeg: 32

vonGohren: 25

Member Stats:

Guest Posters: 0

Members: 815

Moderators: 11

Admins: 1

Forum Stats:

Groups: 3

Forums: 14

Topics: 841

Posts: 3556

Newest Members:

waldlatscher, keithwalmar, shanjaved, opcua-user, DmitryPervukhin, DPer, YeaTeshy, marttin, bouncycastlerentals, Sayan B

Moderators: Jouni Aro: 824, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 336, Heikki Tahvanainen: 402, Jukka Asikainen: 1, Teppo Uimonen: 14

Administrators: admin: 0