Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
TPsOPCServer / TPsOPCConnector Errors
November 5, 2016
19:58, EEST
Avatar
Juan Jaramillo
Member
Members
Forum Posts: 3
Member Since:
November 5, 2016
sp_UserOfflineSmall Offline

Hello, I am experiencing an abnormal behaviour on our OPC clients when comunicating with our OPC server, it gets a lot of error messages on the TPsOPCServer and TPsOPCConnector components, the errors are on method GetStatus and Refresh2, as the error Object indicates for both event methods. I beg somebody can help because is a big client and is being perjudicated as our aplication controls all the production. One thing to note is that in the other 3 plants of the same client, it is not happening at all

November 7, 2016
0:03, EEST
Avatar
Juan Jaramillo
Member
Members
Forum Posts: 3
Member Since:
November 5, 2016
sp_UserOfflineSmall Offline

Hello, is there anybody who can help me?

November 7, 2016
13:03, EEST
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 851
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

If the GetStatus call fails, the reason is because the server cannot be reached. So you have either problems in your network or in your server application, if it is not responding to theses messages.

There is nothing you can do on the client application. The reason why GetStatus is called frequently is to monitor the connection and server state.

November 7, 2016
22:56, EEST
Avatar
Juan Jaramillo
Member
Members
Forum Posts: 3
Member Since:
November 5, 2016
sp_UserOfflineSmall Offline

Thanks Jouni, today I got a more detailed information about the error:
It was: The server cannot convert the data between the requested data type and the canonical data type

November 8, 2016
18:49, EEST
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 851
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

Well, that is obviously a server problem then. It would help to know which data types it is trying to convert between. Maybe it has problems, when the client is not defining the requested data type at all – and it does not understand that the default data type is requested.

You can try to define the data types for each items (or OPC VarLinks) manually.

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
5 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 103

pramanj: 86

ibrahim: 70

kapsl: 57

gjevremovic: 49

TimK: 41

Fransua33: 39

fred: 38

Rainer Versteeg: 32

Thomas Reuther: 31

Member Stats:

Guest Posters: 0

Members: 1105

Moderators: 14

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1009

Posts: 4268

Newest Members:

user1290, gregp, mariohetheringto, normagalindo47, aurelia27u, isobel41d356980, michaeldegli, gqbdolores, kez1399, jaclynmcvay358

Moderators: Jouni Aro: 851, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 545, Heikki Tahvanainen: 402, Jukka Asikainen: 1, Teppo Uimonen: 20, Markus Johansson: 19, Matti Siponen: 53, Lusetti: 0

Administrators: admin: 0