Avatar

Please consider registering
guest

sp_LogInOut Log In sp_Registration Register

Register | Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
OPC Provider & DCOM connection
September 5, 2012
13:16, EEST
Avatar
gbird
Member
Members
Forum Posts: 5
Member Since:
September 4, 2012
sp_UserOfflineSmall Offline

Hi !Smile
I download the “Prosys Sentrol Evaluation Edition” and made reference to lesson 8.
write a opc provider, on the same computer use opc client test connection,
it’s can be working and very well.
But I on other computer use DCOM connect to this opc server,
not any thing happen(other opc server is can be connect),
I check the windows Task Manager,
find the opc server is running, but user is SYSTEM.
(on the same computer, “user” is my user name)
It’s correct?
If I buy official version, this problem will be solved?

September 5, 2012
14:42, EEST
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 946
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

You have to allow access for the “user” to connect to your server in DCOM configuration.

With the official version, you can also compile the server into a service project (as is done for the Prosys OPC Simulation Server) . In that case it will be running on the SYSTEM account.

September 6, 2012
7:29, EEST
Avatar
gbird
Member
Members
Forum Posts: 5
Member Since:
September 4, 2012
sp_UserOfflineSmall Offline

Hi Jouni
Jouni Aro said

You have to allow access for the “user” to connect to your server in DCOM configuration.

I checked the local & remote computer it’s same user account, other opc server(i.e. Kepware) it’s no problem, at the connection
I think… I use a Evaluation Edition, because evaluation start up , server will be show a “splash screen”, user must be press OK button.
In my server computer, splash screen do not show. So OPC server idle in then system, waiting for you answer .

Best Regards
James Wang

September 6, 2012
8:19, EEST
Avatar
Jouni Aro
Moderator
Moderators
Forum Posts: 946
Member Since:
December 21, 2011
sp_UserOfflineSmall Offline

Yes you are correct. If you do not get to press OK in the server then it won’t work.

If you are running it in Windows XP/Vista/7, you can set the Identity of the server (in server specific DCOM settings) to “The interactive user”. This will make the server window appear on screen.

But if you are running it in a Windows Server, there is no “interactive user” and the server window will never be present.

September 6, 2012
12:31, EEST
Avatar
gbird
Member
Members
Forum Posts: 5
Member Since:
September 4, 2012
sp_UserOfflineSmall Offline

Jouni Aro said

Yes you are correct. If you do not get to press OK in the server then it won’t work.

If you are running it in Windows XP/Vista/7, you can set the Identity of the server (in server specific DCOM settings) to “The interactive user”. This will make the server window appear on screen.

But if you are running it in a Windows Server, there is no “interactive user” and the server window will never be present.

Hello Jouni
Thank you very much! I did it, I can do next step workLaugh.

Best Regards
James Wang

Forum Timezone: Europe/Helsinki

Most Users Ever Online: 267

Currently Online:
4 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

hbrackel: 122

pramanj: 86

ibrahim: 74

rocket science: 65

kapsl: 57

gjevremovic: 49

Sabari: 46

Xavier: 42

TimK: 41

fred: 41

Member Stats:

Guest Posters: 0

Members: 3344

Moderators: 17

Admins: 1

Forum Stats:

Groups: 3

Forums: 15

Topics: 1300

Posts: 5561

Newest Members:

UPtato42, fblvicky6629601, elliebloomer44, Manuelagibe, justinafavenc54, sarlaman9, nancymcneal1, elztaim591797, JeffreyAidet, sameisenhower7

Moderators: Jouni Aro: 946, Otso Palonen: 32, Tuomas Hiltunen: 5, janimakela: 0, Pyry: 1, Terho: 0, Petri: 0, Bjarne Boström: 836, Heikki Tahvanainen: 402, Jukka Asikainen: 1, moldzh08: 0, Jimmy Ni: 25, Teppo Uimonen: 21, Markus Johansson: 41, Niklas Nurminen: 0, Matti Siponen: 221, Lusetti: 0

Administrators: admin: 1